Home Video Asylum

TVs, VCRs, DVD players, Home Theater systems and more.

RE: HDMI audio with Sony XBR 65 X850C

You appear to have things connected according to instructions in the manual. Here are some things to confirm:

You have the latest firmware installed on both the Sony TV and KEF?
You are using cables certified for eARC?
You have disconnected and reconnected all HDMI cables?
You have performed a factory reset on both the TV and KEF?
You have configured the TV as follows:

Set the speaker settings to audio out, press HOME, then select [Settings]  [Sound] 
[Speakers]  [Audio system].
Set the HDMI CEC settings on the TV and AV receiver to allow for system audio control for ARC connections.

You have set the digital audio output setting for the TV to PCM (not Dolby, Bitstream, Auto or similar).

This link might be helpful to troubleshoot. It's possible that since the TV is old it is simply a case of a poor (unstable) implementation of ARC from Sony.

It also possible that KEF wants to see an eARC connection from the TV, not an ARC connection.

If all checks out above, it's time for a new TV if you want to use eARC.



This post is made possible by the generous support of people like you and our sponsors:
  Sonic Craft  


Follow Ups Full Thread
Follow Ups
  • RE: HDMI audio with Sony XBR 65 X850C - Doublej 17:10:50 09/08/22 (0)

FAQ

Post a Message!

Forgot Password?
Moniker (Username):
Password (Optional):
  Remember my Moniker & Password  (What's this?)    Eat Me
E-Mail (Optional):
Subject:
Message:   (Posts are subject to Content Rules)
Optional Link URL:
Optional Link Title:
Optional Image URL:
Upload Image:
E-mail Replies:  Automagically notify you when someone responds.